using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\%date\%)(\d{4}-\d{1,2}-\d{1,2})((T)(\d{1,2}\:\d{1,2}))?\#([a-zA-Z]+)?";
string input = @"%date%2023-11-30#
%date%2023-11-30T00:12#
%date%2023-11-30#Berlin
%date%2023-11-30T12:12#Portugal
// error:
%date%#T12:12#
%date%2023-11-30#1131231Portugal
%date%2023-11-30T12:12#Portugal123
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}