re = /(\%date\%)(\d{4}-\d{1,2}-\d{1,2})((T)(\d{1,2}\:\d{1,2}))?\#([a-zA-Z]+)?/
str = '%date%2023-11-30#
%date%2023-11-30T00:12#
%date%2023-11-30#Berlin
%date%2023-11-30T12:12#Portugal
// error:
%date%#T12:12#
%date%2023-11-30#1131231Portugal
%date%2023-11-30T12:12#Portugal123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end