#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([#@\s]|:[)(])|\W"
Local $sString = "this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)