const regex = new RegExp('([#@\\s]|:[)(])|\\W', 'gm')
const str = `this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);