import re
regex = re.compile(r"([#@\s]|:[)(])|\W", flags=re.MULTILINE)
test_str = "this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)