re = /([#@\s]|:[)(])|\W/m
str = 'this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result