$re = '/([#@\s]|:[)(])|\W/m';
$str = 'this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;