import Foundation
let pattern = ##"([#@\s]|:[)(])|\W"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"this is, a placeholder text. I wanna remove symbols like ! and ? but keep @ & # & :)"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)