#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1"
Local $sString = "{{c1 MPSC03P card:1" & @CRLF & _
"{{c50 MPSC03P card:50" & @CRLF & _
"{{c100 MPSC03P card:100" & @CRLF & _
"{{c999 MPSC03P card:999" & @CRLF & _
"" & @CRLF & _
"fails if the numbers don't match:" & @CRLF & _
"{{c1 MPSC03P card:7" & @CRLF & _
"" & @CRLF & _
"if this is an issue, it can be prevented but the approach depends on what comes after card:50:" & @CRLF & _
"{{c5 MPSC03P card:50"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")