import Foundation
let pattern = #"\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{c1 MPSC03P card:1
{{c50 MPSC03P card:50
{{c100 MPSC03P card:100
{{c999 MPSC03P card:999
fails if the numbers don't match:
{{c1 MPSC03P card:7
if this is an issue, it can be prevented but the approach depends on what comes after card:50:
{{c5 MPSC03P card:50
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)