const regex = /\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{c(\\d{1,3}) [^}\\n]*MPSC03P card:\\1', 'gm')
const str = `{{c1 MPSC03P card:1
{{c50 MPSC03P card:50
{{c100 MPSC03P card:100
{{c999 MPSC03P card:999
fails if the numbers don't match:
{{c1 MPSC03P card:7
if this is an issue, it can be prevented but the approach depends on what comes after card:50:
{{c5 MPSC03P card:50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}