import re
regex = re.compile(r"\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1", flags=re.MULTILINE)
test_str = ("{{c1 MPSC03P card:1\n"
"{{c50 MPSC03P card:50\n"
"{{c100 MPSC03P card:100\n"
"{{c999 MPSC03P card:999\n\n"
"fails if the numbers don't match:\n"
"{{c1 MPSC03P card:7\n\n"
"if this is an issue, it can be prevented but the approach depends on what comes after card:50:\n"
"{{c5 MPSC03P card:50")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")