re = /\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1/m
str = '{{c1 MPSC03P card:1
{{c50 MPSC03P card:50
{{c100 MPSC03P card:100
{{c999 MPSC03P card:999
fails if the numbers don\'t match:
{{c1 MPSC03P card:7
if this is an issue, it can be prevented but the approach depends on what comes after card:50:
{{c5 MPSC03P card:50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end