import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{c(\\d{1,3}) [^\\}\\n]*MPSC03P card:\\1";
final String string = "{{c1 MPSC03P card:1\n"
+ "{{c50 MPSC03P card:50\n"
+ "{{c100 MPSC03P card:100\n"
+ "{{c999 MPSC03P card:999\n\n"
+ "fails if the numbers don't match:\n"
+ "{{c1 MPSC03P card:7\n\n"
+ "if this is an issue, it can be prevented but the approach depends on what comes after card:50:\n"
+ "{{c5 MPSC03P card:50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}