using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{c(\d{1,3}) [^}\n]*MPSC03P card:\1";
string input = @"{{c1 MPSC03P card:1
{{c50 MPSC03P card:50
{{c100 MPSC03P card:100
{{c999 MPSC03P card:999
fails if the numbers don't match:
{{c1 MPSC03P card:7
if this is an issue, it can be prevented but the approach depends on what comes after card:50:
{{c5 MPSC03P card:50";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}