#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$"
Local $sString = "anomali_match-4.4.0-5352.rpm" & @CRLF & _
"anomali_link_universal-4.4.0-36.bin" & @CRLF & _
"anomali_link_ESM-4.4.0-1234.bin" & @CRLF & _
"anomali_link_universal_2.4.0_hotfix-2.tar.gz" & @CRLF & _
"Anomali-Ulink-4.5-2139.rpm" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")