using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$";
string input = @"anomali_match-4.4.0-5352.rpm
anomali_link_universal-4.4.0-36.bin
anomali_link_ESM-4.4.0-1234.bin
anomali_link_universal_2.4.0_hotfix-2.tar.gz
Anomali-Ulink-4.5-2139.rpm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}