// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$").unwrap();
let string = "anomali_match-4.4.0-5352.rpm
anomali_link_universal-4.4.0-36.bin
anomali_link_ESM-4.4.0-1234.bin
anomali_link_universal_2.4.0_hotfix-2.tar.gz
Anomali-Ulink-4.5-2139.rpm
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}