use strict;
my $str = 'anomali_match-4.4.0-5352.rpm
anomali_link_universal-4.4.0-36.bin
anomali_link_ESM-4.4.0-1234.bin
anomali_link_universal_2.4.0_hotfix-2.tar.gz
Anomali-Ulink-4.5-2139.rpm
';
my $regex = qr/(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}