package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<product_name>^.*)[-]((?P<ver>\*|\d+(\.\d+){0,2}(\.\*)?))[-](?P<build>.\d*)[.](?P<ext>bin|rpm)$`)
var str = `anomali_match-4.4.0-5352.rpm
anomali_link_universal-4.4.0-36.bin
anomali_link_ESM-4.4.0-1234.bin
anomali_link_universal_2.4.0_hotfix-2.tar.gz
Anomali-Ulink-4.5-2139.rpm
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}