#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$"
Local $sString = "ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found" & @CRLF & _
"ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found" & @CRLF & _
"ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found" & @CRLF & _
"ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found" & @CRLF & _
"ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found" & @CRLF & _
"ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")