using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$";
string input = @"ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}