import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ERROR: \\/var\\/lib\\/jenkins\\/workspace\\/[\\w+\\/]+@script\\/Jenkinsfile not found$";
final String string = "ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found\n"
+ "ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found\n"
+ "ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found\n"
+ "ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found\n"
+ "ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found\n"
+ "ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}