use strict;
my $str = 'ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found';
my $regex = qr/^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}