// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$").unwrap();
let string = "ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}