$re = '/^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$/m';
$str = 'ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);