package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ERROR: \/var\/lib\/jenkins\/workspace\/[\w+\/]+@script\/Jenkinsfile not found$`)
var str = `ERROR: /var/lib/jenkins/workspace/example/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/example/staging@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/bar/production@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/foo/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test@script/Jenkinsfile not found
ERROR: /var/lib/jenkins/workspace/test/test/test@script/Jenkinsfile not found`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}