using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*";
string input = @"class=""rating-inbtn hide-if-zero-113""
class=""rating-inbtn""
class=""hide-if-zero-113 rating-inbtn""
class="" rating-inbtn hide-if-zero-113""
class="" rating-inbtn ""
class="" hide-if-zero-113 rating-inbtn """;
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}