// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*").unwrap();
let string = "class=\"rating-inbtn hide-if-zero-113\"
class=\"rating-inbtn\"
class=\"hide-if-zero-113 rating-inbtn\"
class=\" rating-inbtn hide-if-zero-113\"
class=\" rating-inbtn \"
class=\" hide-if-zero-113 rating-inbtn \"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}