const regex = /\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([a-z0-9-]+)(?:\\s+)?([a-z0-9-]+)?\\s*', 'gmi')
const str = `class="rating-inbtn hide-if-zero-113"
class="rating-inbtn"
class="hide-if-zero-113 rating-inbtn"
class=" rating-inbtn hide-if-zero-113"
class=" rating-inbtn "
class=" hide-if-zero-113 rating-inbtn "`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}