package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*`)
var str = `class="rating-inbtn hide-if-zero-113"
class="rating-inbtn"
class="hide-if-zero-113 rating-inbtn"
class=" rating-inbtn hide-if-zero-113"
class=" rating-inbtn "
class=" hide-if-zero-113 rating-inbtn "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}