$re = '/\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*/mi';
$str = 'class="rating-inbtn hide-if-zero-113"
class="rating-inbtn"
class="hide-if-zero-113 rating-inbtn"
class=" rating-inbtn hide-if-zero-113"
class=" rating-inbtn "
class=" hide-if-zero-113 rating-inbtn "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);