re = /\s*([a-z0-9-]+)(?:\s+)?([a-z0-9-]+)?\s*/mi
str = 'class="rating-inbtn hide-if-zero-113"
class="rating-inbtn"
class="hide-if-zero-113 rating-inbtn"
class=" rating-inbtn hide-if-zero-113"
class=" rating-inbtn "
class=" hide-if-zero-113 rating-inbtn "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end