import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([a-z0-9-]+)(?:\\s+)?([a-z0-9-]+)?\\s*";
final String string = "class=\"rating-inbtn hide-if-zero-113\"\n"
+ "class=\"rating-inbtn\"\n"
+ "class=\"hide-if-zero-113 rating-inbtn\"\n"
+ "class=\" rating-inbtn hide-if-zero-113\"\n"
+ "class=\" rating-inbtn \"\n"
+ "class=\" hide-if-zero-113 rating-inbtn \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}