#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d{2})(\d{2})(\d{6})(\d{8})"
Local $sString = "123456789012345678"
Local $sSubst = "$1\.$2\.$3\.$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)