$re = '/(\d{2})(\d{2})(\d{6})(\d{8})/';
$str = '123456789012345678';
$subst = "$1\.$2\.$3\.$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;