const regex = /(\d{2})(\d{2})(\d{6})(\d{8})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})(\\d{2})(\\d{6})(\\d{8})', 'g')
const str = `123456789012345678`;
const subst = `$1\.$2\.$3\.$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);