import re
regex = re.compile(r"(\d{2})(\d{2})(\d{6})(\d{8})")
test_str = "123456789012345678"
subst = "$1\\.$2\\.$3\\.$4"
result = regex.sub(subst, test_str)
if result:
print(result)