import Foundation
let pattern = #"(\d{2})(\d{2})(\d{6})(\d{8})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123456789012345678"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\.$2\.$3\.$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)