package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2})(\d{2})(\d{6})(\d{8})`)
var str = `123456789012345678`
var substitution = "$1\.$2\.$3\.$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}