using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2})(\d{2})(\d{6})(\d{8})";
string substitution = @"$1\.$2\.$3\.$4";
string input = @"123456789012345678";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}