#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])"
Local $sString = "M&MSAreAGoodSnack"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)