import re
regex = re.compile(r"(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])")
test_str = "M&MSAreAGoodSnack"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)