import Foundation
let pattern = #"(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"M&MSAreAGoodSnack"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)