re = /(?<!^)(?=[A-Z][a-z])|(?<=[a-z])(?=[A-Z])/
str = 'M&MSAreAGoodSnack'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result