# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!\[CDATA\[(.*)\]\]>/$1/;t' <<< "<div><x asd=\"asas\"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>"