import re
regex = re.compile(r"<!\[CDATA\[(.*)\]\]>")
test_str = "<div><x asd=\"asas\"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)