import Foundation
let pattern = #"<!\[CDATA\[(.*)\]\]>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<div><x asd="asas"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}