#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<!\[CDATA\[(.*)\]\]>"
Local $sString = "<div><x asd="asas"><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)