using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!\[CDATA\[(.*)\]\]>";
string substitution = @"$1";
string input = @"<div><x asd=""asas""><![CDATA[<sender>John Smith</sender>]]></x><![CDATA[<sender>John Smith</sender>]]></div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}